Hello Curious Internet User,

WooCommerce 3.5 was released a few days ago (October 23rd, 2018) and although it claims to be backward compatible, there is another issue you will want to be aware of when it comes to WordPress compatibility – WordPress 5.0 which is scheduled for release next week (November 19th, 2018) REQUIRES WooCommerce 3.5.1+, and any legacy WooCommerce versions (prior to 3.5.1) WILL BREAK YOUR ONLINE STORE. Here is a quote directly from WooCommerce themselves:

When WordPress 5.0 is released this month – currently planned for November 19 – your site needs to be running WooCommerce 3.5.1+ to avoid breaking changes.

This can be concerning if your WordPress installation is set to auto-update! It is always best practice to keep your software updated to the latest official stable release, so if you are exercising these best practices, you should have nothing to worry about, but for all of those out there that don’t stay on top of WordPress Plugin Updates, this could bring down your eCommerce solution.

With all the recent developments in ease of use and installation, a lot of people have jumped online and started selling with WooCommerce – I mean really there is no other solution quite as simple and quick to setup, but what is often neglected is updates – Please refer to our post about WordPress Updates & Security for more on this topic.

All of that being said, we are here to help!  We want you to focus on your business and let the tech maintenance and support to us – Please reach out if you think you are at risk or if you would like to rest assured knowing your site and eCommerce solutions are going to be working as expected, 24x7x365!

We look forward to hearing from you and assisting with providing you and your audience a safe and prosperous internet experience!

Thanks!
IT Nachos Support

Contact us now for quick and personal attention

Contact Us - Blog